IPサブネット計算機

IPv4/IPv6 サブネット計算機。CIDR または IP とマスクから、ネットワーク、ブロードキャスト、マスク、ホスト範囲、アドレス数、アドレス種別を求めます。

入力内容とファイルはブラウザ内に留まります

例
ネットワークの詳細

プレフィックスまたはマスク付きのアドレスを入力するか例を選ぶと、ネットワーク、ホスト範囲、アドレス数が表示されます。

ホスト数

合計:

アドレス空間
アドレス
ネットマスク
ワイルドカードマスク
ネットワーク
ブロードキャスト
最小ホスト
最大ホスト
クラス
バイナリ
アドレス
ネットマスク
このページの内容

CIDR 表記から IPv4・IPv6 のサブネットを計算します。ネットワークアドレス、プレフィックスマスク、ホスト/アドレス範囲、正確なアドレス数を表示。IPv4 ではドット区切りのネットマスクも入力でき、ブロードキャスト、ワイルドカードマスク、2 進表示も確認できます。

詳細な機能

IPv4 では 192.168.1.10/24、アドレスとスペース区切りのマスク(192.168.1.10 255.255.255.0)、またはアドレスのみ(/32 として扱います)を入力します。表にはアドレス、ネットマスク、ワイルドカードマスク、プレフィックス付きネットワーク、ブロードキャスト、最初と最後の利用可能ホスト、利用可能数と総数、従来のクラス(A–E)、アドレス種別(プライベート RFC 1918、共有 CGNAT 100.64.0.0/10、ループバック、リンクローカル、ドキュメント用、マルチキャスト、予約済み、パブリック)が並びます。/31 は利用可能アドレス 2 個のポイントツーポイントリンク(RFC 3021)、/32 は単一ホストとして扱います。

コロンを含む入力は IPv6 として解釈します:2001:db8::1/64 やプレフィックスなしのアドレス(/128)。アドレスの省略表記(RFC 5952)と完全表記、ネットワーク、プレフィックスマスク、先頭と末尾のアドレス、正確なアドレス数(最大 2^128 を省略せず表示)を出力します。IPv6 にはブロードキャストがないため、プレフィックス内のすべてのアドレスを数えます。種別バッジはグローバルユニキャスト、ユニークローカル(fc00::/7)、リンクローカル(fe80::/10)、マルチキャスト、ドキュメント用(2001:db8::/32)、ループバックなどを示します。

サブネットに分割 は、計算したネットワークをより長いプレフィックスの同じサイズのサブネットに分割します(例: /24 を 4 つの /26 に、IPv6 の /48 を /64 サブネットに)。サブネットの総数(IPv6 でも正確)、サブネットあたりのアドレス数、各サブネットのホスト範囲(IPv4 ではブロードキャストも)の表を表示します。一覧は最初の 256 個までで、リストをコピー で CIDR 形式でコピーできます。

計算は Rust からコンパイルした小さな WebAssembly モジュールで行います。最初に「計算する」を押したときに読み込まれ、入力したアドレスはどこにも送信されません。ゾーン ID(fe80::1%eth0)や 10.0.0.1-10.0.0.9 のような範囲指定には対応していません。

実用例

オフィス LAN:192.168.1.10/24 → ネットワーク 192.168.1.0/24、ブロードキャスト 192.168.1.255、ホスト 192.168.1.1–192.168.1.254(利用可能 254)、種別「プライベート」。

プレフィックスの代わりにマスク:172.16.0.1 255.240.0.0 は /12 と認識され、ネットワーク 172.16.0.0、ブロードキャスト 172.31.255.255、利用可能ホスト 1,048,574。

ポイントツーポイントリンク:10.0.0.1/31 では 10.0.0.0 と 10.0.0.1 の 2 アドレスが利用可能です。RFC 3021 により /31 ではネットワーク/ブロードキャストを予約しません。

IPv6 /64:2001:db8:abcd:12::1/64 → ネットワーク 2001:db8:abcd:12::、末尾アドレス 2001:db8:abcd:12:ffff:ffff:ffff:ffff、アドレス数 18,446,744,073,709,551,616(2^64)、種別「ドキュメント用」。

このツールの使い方

  1. アドレスを入力

    「IPアドレス / CIDR」に IPv4 または IPv6 アドレスを入力します。プレフィックス付き(10.20.30.40/22、2001:db8::/48)か、IPv4 ならスペースの後にマスクを書きます。

  2. 計算

    「計算する」を押すか Enter キーを押します。「例」のボタンをクリックすると、入力と計算が一度に行われます。

  3. 確認してコピー

    表でネットワーク、範囲、アドレス数を確認し、コピーアイコンでネットワークやブロードキャスト(IPv6 では末尾アドレス)をコピーします。

ヒントとベストプラクティス

  • ネットワークアドレスそのものを入力する必要はありません:10.20.30.40/22 はネットワーク 10.20.28.0 に正規化されます。
  • プレフィックスなしの IPv4 は /32、IPv6 は /128 として扱われます。
  • 種別バッジは入力したアドレスについての表示です:100.64.0.1 は RFC 1918 のプライベートではありませんが、「パブリック」ではなく「共有 (CGNAT)」です。
  • IPv6 の LAN サブネットは通常 /64、ポイントツーポイントリンクには /127 を使います(RFC 6164)。
  • 2 進表示(IPv4 のみ)で、マスクがネットワーク部とホスト部をどこで分けているかが一目でわかります。